Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Event Manager - Invoicing Issue
Incident Report for Dude Solutions
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 12:08 EDT
Investigating
We are currently investigating an issue related to Invoices in Event Manager. Invoices may reflect an incorrect dollar amount. This could impact recipients when attempting to make an invoice payment. This is a high priority issue and our team is working to correct it as quickly as possible. The correct invoice amount can be found on the Event Manager Invoice List.
Posted May 24, 2021 - 10:16 EDT
This incident affected: Event Management (Event Manager).