Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Correction: Third Party Certificate Update
Incident Report for Dude Solutions
Update
Let's Encrypt, a third party organization (https://letsencrypt.org), has updated a certificate on their end which could cause a "connection is invalid" message when accessing our Dude Solutions products. This issue can be corrected by one or more of the following steps:

1. Clear your browser cache
2. Restart your browser
3. Update your browser
4. Try a different browser
5. Reboot your computer
6. Update your operating system

You may be able to perform these updates yourself, but if you have an internal IT support department please contact them for support. You may also contact us if that does not resolve the issue at support@dudesolutions.com or 877-883-8337.
Posted Sep 30, 2021 - 12:51 EDT
Identified
Let's Encrypt has updated a certificate which could cause a "connection is invalid" message when accessing our Dude Solutions products. This issue can be corrected by applying outstanding updates to your browser or operating system. You may be able to perform these updates yourself, but if you have an internal IT support department please contact them for support. You may also contact us if that does not resolve the issue at support@dudesolutions.com or 877-883-8337.
Posted Sep 30, 2021 - 11:57 EDT
This incident affects: TheWorxHub (TheWorxHub - Senior Living USA, TheWorxHub - USA - Healthcare, TheWorxHub - USA - Api, TheWorxHub - Senior Living Canada), IT Asset Management (Help Desk, Incident, Insight, Mobile Device Management), Safety (CrisisManager, Safety Center), Community Development (SmartGov, ATS), Work and Asset Management (Asset Essentials, MaintenanceDirect, PMDirect, Planned Maintenance, Work Order, Zion.Web, Maintenance Manager, Mobile311, ConnectGIS, CapitalForecastDirect, Critical Alarm Automation, SchoolDude WorkCenter, Capital Forecast, Critical Alarm, FacilityDude Work Center, InventoryDirect, Inventory Wireless, Inventory, Asset Essentials Analytics), Energy Management (Energy Manager, UtilityDirect, UtilityManager, UtilityTrac), Dude Intelligence, MySchoolBuilding, MyFacilityDude, and Event Management (Event Manager, Facility Schedule, FSDirect, FSAutomation, Facility Schedule, TripDirect).