Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Users Unable to Access Mobile311
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 10:45 EDT
Investigating
Our team is currently investigating an issue impacting access to Mobile311. The team is actively addressing this issue and working to restore functionality as quickly as possible. We appreciate your patience and understanding during this process.
Posted Apr 10, 2024 - 09:22 EDT
This incident affected: Work and Asset Management (Mobile311).