Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Expired Certificate Errors
Incident Report for Brightly Software
Resolved
This incident has been resolved. Please see below for additional information:

If you are experiencing an issue and are receiving any messages that reference “expired certificate”, it is likely due to an expired authority within the certificate chain provided by your browser or device operating system.

This issue can be corrected by applying outstanding updates to your browser or operating system. You may be able to perform these updates yourself, but if you have an internal IT support department please contact them for support. You may also contact us if that does not resolve the issue at support@dudesolutions.com or 877-883-8337.

You can reference this link for your IT support department - https://support.sectigo.com/articles/Knowledge/Sectigo-AddTrust-External-CA-Root-Expiring-May-30-2020
Posted Jun 02, 2020 - 09:32 EDT
Update
The Asset Essentials Android mobile application is now available to download in the Google Play store. Please upgrade your Android device to the newest version (1.53.2) at your earliest convenience. This version contains the fix for the widespread expired certificate authority.
Posted Jun 01, 2020 - 18:09 EDT
Update
Dude Solutions Asset Essentials Android mobile application is impacted by this same wide spread expired certificate authority. We are currently making updates to our Android application and expect to have a new version available shortly for download from the Google Play Store. We will provide notification when the new download is available.
Posted Jun 01, 2020 - 14:16 EDT
Investigating
If you are experiencing an issue today and are receiving any messages that reference “expired certificate”, it is likely due to an expired authority within the certificate chain provided by your browser or device operating system.

This issue can be corrected by applying outstanding updates to your browser or operating system. You may be able to perform these updates yourself, but if you have an internal IT support department please contact them for support. You may also contact us if that does not resolve the issue at support@dudesolutions.com or 877-883-8337.

You can reference this link for your IT support department - https://support.sectigo.com/articles/Knowledge/Sectigo-AddTrust-External-CA-Root-Expiring-May-30-2020
Posted Jun 01, 2020 - 12:17 EDT
This incident affected: IT Asset Management (Help Desk, Insight), Work and Asset Management (Asset Essentials), and Energy Management (Energy Manager).