Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Users unable to access Asset Essentials
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 08:20 EDT
Update
We are continuing to investigate this issue.
Posted Mar 15, 2024 - 08:20 EDT
Investigating
Our team is currently investigating an issue impacting access to Asset Essentials. The team is actively addressing this issue and working to restore functionality as quickly as possible. We appreciate your patience and understanding during this process. We will continue to post updates on this page every hour.
Posted Mar 15, 2024 - 08:10 EDT
This incident affected: Work and Asset Management (Asset Essentials).