Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

GIS - Performance Issues
Incident Report for Brightly Software
Resolved
Our engineers have been monitoring the application. The issue now appears to be resolved. Thank you for your patience!
Posted Jul 13, 2018 - 13:19 EDT
Investigating
Our development team is currently investigating performance issues with our GIS application. We apologize for any inconveniences that this causes and will provide another update shortly!
Posted Jul 13, 2018 - 10:42 EDT