Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - Work Order Labor Issues
Incident Report for Dude Solutions
Resolved
The fix was a success! Thanks so much for hanging in there!
Posted 2 months ago. Jun 14, 2019 - 10:12 EDT
Identified
Our development team has identified the issue and is currently working on the fix. Thank you so much for your patience while we work towards a resolution. We will continue to provide updates on this page.
Posted 2 months ago. Jun 13, 2019 - 16:59 EDT
Investigating
Please be aware that our development team is currently investigating issues with adding labor hours to work orders in Asset Essentials. This is specifically affecting the Maintenance Technician role. We apologize for any inconveniences that this causes and will provide another update shortly.
Posted 2 months ago. Jun 13, 2019 - 08:48 EDT
This incident affected: Work and Asset Management (Asset Essentials).