Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Application Performance Degraded
Incident Report for Dude Solutions
Resolved
Everything looks great! This incident has been resolved. Thanks again for your patience!
Posted Aug 07, 2019 - 10:54 EDT
Investigating
We're currently investigating performance issues with the application(s). We are very sorry for the inconvenience. We are investigating and will have an update for you soon.
Posted Aug 07, 2019 - 10:32 EDT