Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

SchoolDude SSO Certification
Incident Report for Dude Solutions
Resolved
This incident has been resolved. If you do continue to receive a certificate error, please reach out to our Support team at support@dudesolutions.com or 1-877-655-3833. Thank you!
Posted Jul 30, 2020 - 16:58 EDT
Update
Our development team will be performing maintenance tonight to assist in the SchoolDude SSO certification process. Please continue to reach out to our Support team at support@dudesolutions.com or 1-877-655-3833 if you receive a certificate error. Thank you!
Posted Jul 29, 2020 - 17:17 EDT
Investigating
Please be aware that we have updated our SchoolDude SSO certification. If you are receiving a certificate error this morning, please contact our support team at support@dudesolutions.com or 1-877-655-3833. Our team will assist your IT department in making all necessary updates. Thank you!
Posted Jul 29, 2020 - 10:58 EDT
This incident affected: Energy Management (ConserveDirect, UtilityDirect), IT Asset Management (Incident), Work and Asset Management (MaintenanceDirect, PMDirect, CapitalForecastDirect, InventoryDirect, Inventory Wireless), Event Management (FSDirect, FSAutomation, TripDirect), and MySchoolBuilding.