Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Dude Solutions Support Issue
Incident Report for Dude Solutions
Resolved
This incident has been resolved. Thanks for your patience!
Posted 14 days ago. Oct 01, 2019 - 07:53 EDT
Identified
We apologize for the delay in response time upon you contacting the Dude Solutions Support Team. There was an unknown issue taking place with our email queue, preventing your case from reaching our department. That issue has been corrected and we are diligently working to get you the information or assistance requested. We apologize for the inconvenience. Please call our support line (877-868-3833) if you need immediate assistance.
Posted 15 days ago. Sep 30, 2019 - 14:59 EDT
This incident affected: IT Asset Management (Help Desk, Incident, Insight, Mobile Device Management), Community Development (SmartGov, ASMi, ATS, Panoramic), TheWorxHub (TheWorxHub - USA, TheWorxHub - USA - Healthcare, TheWorxHub - USA - Api, TheWorxHub - Canada), Energy Management (ConserveDirect, Energy Manager, UtilityDirect, UtilityManager, UtilityTrac), Work and Asset Management (Asset Essentials, MaintenanceDirect, PMDirect, Planned Maintenance, Work Order, Zion.Web, Maintenance Manager, Mobile311, ConnectGIS, CapitalForecastDirect, Critical Alarm Automation, SchoolDude WorkCenter, Capital Forecast, Critical Alarm, FacilityDude Work Center, InventoryDirect, Inventory Wireless, Inventory), Event Management (Active Data Calendar, Event Manager, Facility Schedule, FSDirect, FSAutomation, Facility Schedule, TripDirect), Safety (CrisisManager, Safety Center), and Dude Intelligence, MySchoolBuilding, MyFacilityDude.