Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - Mobile App SSO Issues
Incident Report for Dude Solutions
Resolved
This issue has been resolved. Thank you for your patience!
Posted Jun 26, 2019 - 09:43 EDT
Identified
The root cause has been identified and the fix is being implemented. We will provide another update once the issue is resolved. Thank you for your patience!
Posted Jun 25, 2019 - 16:36 EDT
Investigating
Please be aware that our development team is currently investigating issues with our Asset Essentials mobile app, which specifically affects our SSO clients. We apologize for this inconvenience and will continue to provide updates on this page. Thank you for your patience while we work to resolve this issue!
Posted Jun 25, 2019 - 13:53 EDT
This incident affected: Work and Asset Management (Asset Essentials).