Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - Printing Issue
Incident Report for Dude Solutions
Resolved
This incident has been resolved. If you still see this issue in your account, a refresh of the browser will resolve the issue. There should no longer be a need to clear cache in the Chrome browser. Thank you for your patience!
Posted Feb 12, 2021 - 13:44 EST
Investigating
Our development team is currently investigating an issue with printing work orders and reports in Asset Essentials in the Google Chrome browser. As a work around, please clear your cache in Chrome. Thank you for your patience while we work to resolve this issue!
Posted Feb 12, 2021 - 11:10 EST
This incident affected: Work and Asset Management (Asset Essentials).