Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Energy Manager - Login Issues
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted Jan 29, 2021 - 08:38 EST
Investigating
Our development team is currently investigating login issues with EnergyManager. We will continue to provide updates on this page. As a workaround, please select "No" when the New Version Available box pops up. This will not affect any data in your account and will allow you to successfully login. Thank you for your patience while we work to resolve this issue!
Posted Jan 12, 2021 - 09:29 EST
This incident affected: Energy Management (Energy Manager).