Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

MySchoolBuilding - Submitting Requests Issue
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted Aug 13, 2021 - 12:12 EDT
Investigating
Please be aware that our development team is currently investigating intermittent issues with submitting requests via MySchoolBuilding. Requests may not show as being submitted or it may take several attempts to submit. We apologize for this inconvenience and will continue to provide updates on this page.
Posted May 24, 2021 - 12:48 EDT
This incident affected: MySchoolBuilding.