Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - Interruption of Service
Incident Report for Brightly Software
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again. Thank you for your patience!
Posted Jul 15, 2020 - 14:16 EDT
Update
We continue to investigate this issue as our highest priority. Thank you for your patience!
Posted Jul 15, 2020 - 13:31 EDT
Investigating
We are currently looking into an interruption of service with Asset Essentials. We apologize for any inconvenience that this causes and will continue to provide updates on this page. Thank you for your patience while we work to resolve this issue.
Posted Jul 15, 2020 - 12:41 EDT
This incident affected: Work and Asset Management (Asset Essentials).