Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Energy Manager - Login Page Redirect
Incident Report for Dude Solutions
Resolved
This incident has been resolved and you may now login via login.schooldude.com. Thanks for your patience!
Posted Nov 09, 2020 - 12:59 EST
Investigating
Our development team is currently investigating an issue when logging into Energy Manager through login.schooldude.com. Login via this page is currently redirecting clients to a demo request page. While we work to resolve this issue, please use energy.dudesolutions.com to login. Thank you for your patience!
Posted Nov 09, 2020 - 11:34 EST
This incident affected: Energy Management (Energy Manager).