Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

HelpDesk - Email to Ticket Issue
Incident Report for Brightly Software
Resolved
This incident has been resolved. Thank you for your patience!
Posted Sep 30, 2021 - 15:00 EDT
Investigating
Please be aware that we are currently investigating an issue with email to ticket functionality within HelpDesk. We apologize for this inconvenience and will continue to provide updates on this page.
Posted Sep 30, 2021 - 10:36 EDT
This incident affected: IT Asset Management (Help Desk).