Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Event Manager - Events List Issue
Incident Report for Dude Solutions
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again. Thank you for your patience!
Posted Feb 24, 2021 - 12:49 EST
Investigating
We are currently investigating an issue with accessing the events list in Event Manager. We apologize for this inconvenience and will continue to provide updates on this page.
Posted Feb 24, 2021 - 12:06 EST
This incident affected: Event Management (Event Manager).