Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

SchoolDude - Email Notification Issue
Incident Report for Dude Solutions
Resolved
The issue has been resolved. Thanks so much for for your patience!
Posted Oct 15, 2020 - 14:00 EDT
Investigating
Please be aware that our development team is currently investigating an issue with email notifications in our SchoolDude applications. Clients may not be receiving email notifications at this time. We apologize for the inconvenience and will continue to provide updates on this page. Thank you for your patience!
Posted Oct 15, 2020 - 10:38 EDT
This incident affected: Energy Management (ConserveDirect, UtilityDirect), Work and Asset Management (MaintenanceDirect, PMDirect, CapitalForecastDirect, InventoryDirect), IT Asset Management (Incident), and Event Management (Facility Schedule, FSDirect, FSAutomation, Facility Schedule, TripDirect).