Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

HelpDesk - Login Issues
Incident Report for Dude Solutions
Resolved
We have implemented a fix for this issue and the applications are now accessible. Thank you for your patience while we worked to resolve this issue!
Posted Oct 05, 2021 - 13:28 EDT
Update
Dude Solutions continues to investigate this issue as our highest priority. Thank you for your patience while we work to resolve this issue.
Posted Oct 05, 2021 - 08:32 EDT
Update
All resources are currently being utilized to investigate this issue. We apologize for the inconvenience and will continue to provide updates on this page. Thank you for your patience.
Posted Oct 04, 2021 - 18:54 EDT
Update
We continue to investigate this issue as our highest priority. Thank you for your patience!
Posted Oct 04, 2021 - 14:34 EDT
Investigating
Please be aware that we are currently investigating HelpDesk login issues. We apologize for the inconvenience and will continue to provide updates on this page.
Posted Oct 04, 2021 - 08:37 EDT
This incident affected: IT Asset Management (Help Desk, Insight, Mobile Device Management).