Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Brightly - Internet Service Provider Issue
Incident Report for Brightly Software
Resolved
This incident has been resolved. Thank you for your patience!
Posted Jun 22, 2022 - 14:28 EDT
Investigating
We are currently experiencing a disruption with our internet service provider. This may cause access issues with some of our Brightly applications. We are actively monitoring this outage and will continue to provide updates on this page. Thank you for your patience!
Posted Jun 22, 2022 - 12:39 EDT
This incident affected: IT Asset Management (Help Desk, Insight, Mobile Device Management) and Dude Intelligence.