Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

HelpDesk - Login Issue
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 12:03 EDT
Investigating
Our team is currently investigating an issue preventing access to HelpDesk and Insight. This is being investigated as our top priority and we will work to have a resolution out as quickly as possibly. Thank you for your patience.
Posted Aug 10, 2022 - 09:50 EDT
This incident affected: IT Asset Management (Help Desk, Insight).