Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

TheWorxHub Performance Issues
Incident Report for Dude Solutions
Resolved
Everything looks great! This incident has been resolved. Thanks again for your patience!
Posted about 2 months ago. Apr 02, 2019 - 08:57 EDT
Investigating
We’re experiencing some performance issues impacting TheWorxHub clients. We are actively working on a resolution and apologize for any inconveniences. We'll update you soon!
Posted about 2 months ago. Apr 02, 2019 - 08:12 EDT
This incident affected: TheWorxHub (TheWorxHub - USA - Healthcare).