Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - Login Issues
Incident Report for Brightly Software
Resolved
Login issues have been resolved. Thank you for your patience while we worked to resolve this issue!
Posted Sep 03, 2020 - 21:12 EDT
Investigating
Please be aware that our development team is investigating login issues with Asset Essentials. We are utilizing all resources to resolve this issue. We apologize for any inconvenience that this causes and will continue to provide updates on this page.
Posted Sep 03, 2020 - 19:07 EDT
This incident affected: Work and Asset Management (Asset Essentials).