Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Login Issue with Help Desk and Dude Intelligence
Incident Report for Brightly Software
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again.
Posted Mar 21, 2018 - 12:33 EDT
Investigating
Some of our clients have reported issues logging into our Help Desk and Dude Intelligence products. Our engineering teams are looking into it. We are sorry for the inconvenience. We will provide an update soon!
Posted Mar 21, 2018 - 11:27 EDT
This incident affected: IT Asset Management (Help Desk), Dude Intelligence, and Work and Asset Management (Maintenance Manager).