Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Performance issues when entering transactions in MaintenanceDirect
Incident Report for Brightly Software
Resolved
Everything looks great! This incident has been resolved. Thanks again for your patience!
Posted Sep 22, 2016 - 07:18 EDT
Investigating
We’re experiencing some issues when entering transactions for technicians in MD . We are actively working on a resolution and apologize for any inconveniences. Hang tight and we'll update you soon!
Posted Sep 21, 2016 - 10:09 EDT