Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - SSO Login Issues
Incident Report for Dude Solutions
Resolved
The issue has been resolved and we are taking preventative measures to ensure this doesn't happen again. Thank you for your patience!
Posted Jun 05, 2019 - 11:12 EDT
Identified
The issue has been identified and our development team is implementing a fix. We will continue to provide updates on this page. Thank you so much for your patience.
Posted Jun 05, 2019 - 07:33 EDT
Investigating
Please be aware that our development team is currently investigating login issues with our Asset Essentials SSO clients. We apologize for the inconvenience and will provide another update shortly.
Posted Jun 04, 2019 - 14:53 EDT
This incident affected: Work and Asset Management (Asset Essentials).