Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

SchoolDude Applications - Performance Issues
Incident Report for Brightly Software
Resolved
This issue is now resolved. We have implemented several infrastructure and network changes to ensure performance remains at an optimal level. Thank you for your patience!
Posted Nov 04, 2020 - 09:17 EST
Monitoring
We have implemented several infrastructure and network changes and the issue is greatly improved. We will continue to monitor the situation to ensure performance remains at an optimal level. Thank you for your patience!
Posted Oct 12, 2020 - 09:24 EDT
Update
Dude Solutions is fully committed to bringing performance back to an acceptable level. While we have made several improvements in our applications, we continue to utilize our consulting resources to identify the areas that need performance refinement. We assure you that this is our top priority and will continue to work around the clock until we have a resolution. Thank you for your continued patience!
Posted Oct 01, 2020 - 15:22 EDT
Update
Our development team continues to investigate performance issues with our SchoolDude applications. This is our top priority until we find a resolution. We thank you for your patience and apologize for the inconvenience this has caused. Updates will continue to be provided on this page.
Posted Sep 16, 2020 - 10:27 EDT
Update
We are continuing to investigate the slowness issue with our applications. All resources are currently being utilized to ensure performance is brought back to an optimal level. We assure you this is our top priority here at Dude Solutions and we greatly apologize for the inconvenience that this has caused. We will continue to provide updates on this page.
Posted Sep 09, 2020 - 15:31 EDT
Update
All resources are currently being utilized to ensure performance is brought back to an optimal level. We have also engaged consultants who have specific performance expertise to allow us to more quickly resolve these issues. We assure you this is our top priority here at Dude Solutions and we greatly apologize for the inconvenience that this has caused. We will continue to provide updates on this page.
Posted Sep 01, 2020 - 17:18 EDT
Update
Our development team is working around the clock to bring performance back to an acceptable level. We thank you for your continued patience and apologize for any inconvenience that this has caused.
Posted Aug 25, 2020 - 09:39 EDT
Investigating
Our development team is currently looking into performance issues reported in our Schooldude applications. We will continue to provide updates on this page. Thank you for your patience while we work to get this resolved!
Posted Aug 18, 2020 - 15:44 EDT
This incident affected: Work and Asset Management (MaintenanceDirect, PMDirect, CapitalForecastDirect, SchoolDude WorkCenter, InventoryDirect), IT Asset Management (Incident), Energy Management (UtilityDirect), Event Management (FSDirect, TripDirect), and MySchoolBuilding.