Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Disruption of Service - Event Manager
Incident Report for Dude Solutions
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again. Thank you for your patience.
Posted Apr 30, 2020 - 13:59 EDT
Investigating
Our development team is looking into a disruption of service in Event Manager. We apologize for any inconvenience that this causes and will continue to provide updates on this page.
Posted Apr 30, 2020 - 13:39 EDT
This incident affected: Event Management (Event Manager).