Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

SchoolDude - Assigning Work Orders Issue
Incident Report for Dude Solutions
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again.
Posted 4 months ago. May 29, 2019 - 08:48 EDT
Investigating
Some of our SchoolDude clients have reported errors when assigning work orders. Our development team is currently testing a fix for this issue. In the meantime, to assign work orders, please use the "Search For" box to search a particular work order ID. You will be able to assign the work order or make any changes from this page. Thank you for your patience while we work to resolve this issue!
Posted 4 months ago. May 28, 2019 - 10:13 EDT
This incident affected: Work and Asset Management (MaintenanceDirect).