Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Event Manager - Slowness Issues
Incident Report for Dude Solutions
Resolved
This issue has been resolved. Thank you for your patience!
Posted 29 days ago. Sep 16, 2019 - 08:04 EDT
Update
Thank you for your patience while our development team continues to investigate this issue as our top priority. We apologize for any inconveniences that this has caused and will continue to provide updates on this page.
Posted about 2 months ago. Aug 27, 2019 - 07:40 EDT
Update
Our development team continues to investigate this issue as our highest priority. Thank you for your patience and we apologize for any inconveniences that this causes. We will continue to provide updates on this page.
Posted about 2 months ago. Aug 21, 2019 - 08:50 EDT
Investigating
We are currently experiencing slowness issues/spinning wheel when using the custom forms in Event Manager. Our engineers are aware of the issue and are working to resolve this as soon as possible. We will continue to provide updates on this page. Thank you for your patience!
Posted 2 months ago. Aug 14, 2019 - 10:21 EDT
This incident affected: Event Management (Event Manager).