Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

SchoolDude - Login Issues
Incident Report for Dude Solutions
Resolved
This incident has been resolved. Thank you for your patience and we apologize for any inconveniences that this caused!
Posted 27 days ago. Apr 22, 2019 - 15:45 EDT
Investigating
Please be aware that our development team is currently investigating login issues with our SchoolDude products, including the Work Center app. We will provide another update shortly. Thank you for your patience and we apologize for any inconveniences!
Posted about 1 month ago. Apr 18, 2019 - 07:47 EDT
This incident affected: SchoolDude (CapitalForecastDirect, ConserveDirect, Crisis Manager, Critical Alarm Automation, FSDirect, FSAutomation, Help Desk, Incident, Insight, InventoryDirect, MaintenanceDirect, Mobile Device Management, MySchoolBuilding, PMDirect, TripDirect, UtilityDirect, UtilityManager, WorkCenter).