Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Issue Submitting Requests in Event Manager
Incident Report for Dude Solutions
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again.
Posted about 2 months ago. Jun 28, 2019 - 07:11 EDT
Investigating
Please be aware that our development team is currently investigating an issue with submitting event requests in Event Manager. We apologize for any inconveniences. We'll update you soon!
Posted about 2 months ago. Jun 27, 2019 - 12:24 EDT
This incident affected: Event Management (Event Manager).