Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Issue saving information containing fixtures in Internet Explorer for SmartGov
Incident Report for Dude Solutions
Resolved
The fix was a success! Thanks so much for hanging in there!
Posted 2 days ago. May 17, 2019 - 20:03 EDT
Investigating
We are working on an issue where users are unable to save information on pages containing fixtures when using the Internet Explorer web browser. If you are experiencing this, please switch to Chrome if possible. We expect to have the issue resolved soon
Posted 2 days ago. May 17, 2019 - 17:38 EDT
This incident affected: Community Development (SmartGov).