Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

WorkCenter Mobile App Issues
Incident Report for Dude Solutions
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again. Thank you for your patience!
Posted May 22, 2020 - 09:22 EDT
Update
We continue to investigate these issues as our highest priority. Thank you for your patience while we work get these resolved.
Posted May 20, 2020 - 10:11 EDT
Investigating
Our development team continues to investigate two high priority issues with the WorkCenter mobile app: crashing upon login and adding time to work orders. We apologize for any inconvenience that this has caused and will continue to provide updates on this page. Thank you so much for your patience.
Posted May 12, 2020 - 15:20 EDT
This incident affected: Work and Asset Management (SchoolDude WorkCenter, FacilityDude Work Center).