Dude Solutions
Status Page

The Dude Solutions status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Login issues with UtilityManager and UtilityTrac
Incident Report for Dude Solutions
Resolved
This incident has been resolved. We have identified the issue and are taking preventative measures to ensure this doesn't happen again.
Posted about 2 months ago. Jul 05, 2019 - 11:31 EDT
Identified
We have discovered a workaround to log into UT/UM while we work on developing a permanent fix. The workaround for UtilityManager clients would be to go to https://ut.schooldude.com and enter your regular credentials along with "UTSD" as the "Datasource". For UtilityTrac clients, please go to https://ut.facilitydude.com and enter your regular credentials, the "Datasource" will either be JCI or UTP. We will update you again when we have resolved the issue. Thanks for your patience.
Posted about 2 months ago. Jul 01, 2019 - 13:11 EDT
Investigating
We’re experiencing login issues with UtilityManager and UtilityTrac. We are actively working on a resolution and apologize for any inconveniences. We'll update you soon!
Posted about 2 months ago. Jul 01, 2019 - 10:27 EDT
This incident affected: Energy Management (UtilityManager, UtilityTrac).