Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Outage - Toll Free Phone Numbers
Incident Report for Brightly Software
Resolved
Everything looks great! This incident has been resolved. Thanks again for your patience!
Posted Aug 29, 2016 - 17:11 EDT
Investigating
If you are having trouble reaching us, please use the phone number 919-816-8237. Thanks!
Posted Aug 29, 2016 - 08:40 EDT